Mtec200

Greg burns

New Member
Well it trips out the whole time then the hopper fills with water jamming it and the pipes so u spend most of your day cleaning it out and so forth and it makes a hellish mess
 

Plasterers1StopShop

Private Member
@Greg burns I thought you had sold your machine mate?

If it is tripping, this is normally down to it being ran off extension leads, or the consistency being set incorrectly

If the hopper is back filling, this can be down to your R/S being set incorrectly and over tightened or the consistency again being wrong.

We offered to come up and help you a few months ago mate, I had our guy up and around Scotland and was willing to send him across to you also. Give me a call if you would like this arranged
 

bobski

Active Member
The power on the machine trips.cant keep water pressure either

Had the power issue once.

Builder rang us a 30m extension lead out to a cabin in a field and said it'd be sufficient.

Nope. Stalled.

Moved it - plugged into a 16A socket.

Ran fine then on.
 

Vincey

Private Member
Agree , my water pump always used to trip out when plugged into an extension lead , in end I made a lead up from electrical whole sale shop 20 m long direct to a plug and to pump
 

Greg burns

New Member
@Greg burns I thought you had sold your machine mate?

If it is tripping, this is normally down to it being ran off extension leads, or the consistency being set incorrectly

If the hopper is back filling, this can be down to your R/S being set incorrectly and over tightened or the consistency again being wrong.

We offered to come up and help you a few months ago mate, I had our guy up and around Scotland and was willing to send him across to you also. Give me a call if you would like this arranged
No haven't sold it yet but waiting on couple of people getting back so thought we would try it again but its no use we have tried everything and it dont work sence so we wont be using it again as lost a lot of materials through it and days of labour
 

Plasterers1StopShop

Private Member
No haven't sold it yet but waiting on couple of people getting back so thought we would try it again but its no use we have tried everything and it dont work sence so we wont be using it again as lost a lot of materials through it and days of labour
It 100% works and sprays K-rend mate. Why don’t you get Dave up to see you to sort it out?
 

Greg burns

New Member
It 100% works and sprays K-rend mate. Why don’t you get Dave up to see you to sort it out?
Appreciate u wanting to send a guy up but none of us want to try it again and i have no patients to work with it now and we are quicker at hand applying it.plus i am not wasting anymore days trialling it as we have lost enough days it hasn't been able to do one house since i got it in October
 

Plasterers1StopShop

Private Member
Appreciate u wanting to send a guy up but none of us want to try it again and i have no patients to work with it now and we are quicker at hand applying it.plus i am not wasting anymore days trialling it as we have lost enough days it hasn't been able to do one house since i got it in October
I completely understand mate, but the quickest solution - as previously said, is for us to come to you. I have tried arranging it before

I know David really wants to get the most out of it and I’m confident we can make it happen for you
 

bobski

Active Member
What u spraying krend?

Sprays anything mate.

That issue was with power though - not product.

Last week was using Weber, plugged tranny straight into customers kitchen socket.

Tried a couple of walls with wet mix 2 passes. Also tried one fat coat at 20mm over s + c scratch.

Also used k rend aswell mate. Big improvement on what it used to be for me.
 

Greg burns

New Member
Sprays anything mate.

That issue was with power though - not product.

Last week was using Weber, plugged tranny straight into customers kitchen socket.

Tried a couple of walls with wet mix 2 passes. Also tried one fat coat at 20mm over s + c scratch.

Also used k rend aswell mate. Big improvement on what it used to be for me.
Am just having no luck with it and i just end up going mental on it lol
 

essexandy

The Lake Governor
Am just having no luck with it and i just end up going mental on it lol
I'll bet that if you made sure that you had a suitable power supply and were shown the correct setup/running process, you'd be flying. We had exactly the same issues with our Ritmo, made some chunkier (for want of a better term) extension leads, had the gear running wetter than for hand application and all the tripping issues went away.
 
Top