Battery

Status
Not open for further replies.

spunky

Private Member
Our batteries died on the Genny is this normal? It's not had loads of use and sits still for 2 weeks tops just seems a bit weird?
 

keithuk

Private Member
Our batteries died on the Genny is this normal? It's not had loads of use and sits still for 2 weeks tops just seems a bit weird?
You , had the battery tested Dave , to say it is ****** ? changed mine after about 5 years mate :RpS_confused:
 

PFTwales

Well-Known Member
Maybe the rectifier (which charges it) is ****** and you have just used all the power out of it. It would last a fair while on just starting it once a day.
Charge it back up and get a spark to put his testers on it. it should say 12v then when you start the genny check it again and if its higher than 12 volts then its charging.
 

spunky

Private Member
Haven't tried charging it jenks we're jump starting it off the van and when we turn it off and try it again we get zilcho, if we get it running and get a sparky to test it and then it says more than 12v does it still mean it's charging?
 
Sounds serious dave it could be one of 2 things wrong with it its either the warp drive gone on it or its the centrifugal transponder .... I can give you a quote but it wont be cheap mate


I'm using The Plasterers Forum Mobile App
 

Plasterers1StopShop

Private Member
Exactly as Ian said mate. Let us know if u need it looked at. Did u get it from us? Will check on warranties etc


I'm using The Plasterers Forum Mobile App
 
Status
Not open for further replies.
Top